Tags

, , , , , ,

My service provider (iPrimus) provided Huawei CPE (HG659) for my NBN connection. The modem was not bad (I have used it for my old ADSL link) but for some reason it’s not working properly with new NBN connection. The link dropped randomly and it not resolved until and unless I power cycle the modem. Was not even able to ping CPE IP.

I am big fan of Mikrotik and thought I would be great to have MT as CPE.  I bought a MikroTik RB760iGS hEX S. It has decent hardware and comes with 5 Gig ports + 1 SFP port.

All the configuration is straight forward; but only catch is VLAN. iPrimus uses VLAN 100. Below is the Huawei CPE configuration:

iprimus.png

A. Mikrotik Configuration:

Do the basic configuration like LAN IP address, DHCP and caching DNS (if required). Following steps are for PPPoE Client and NAT.

Step 1: Add new interface for VLAN 100. In my case sfp1 is the WAN interface
/interface vlan add interface=sfp1 name=internet_tr069_eth_vid_100 vlan-id=100

Step 2: Configure PPPOE client and use the VLAN interface
/interface pppoe-client
add add-default-route=yes disabled=no \
interface=internet_tr069_eth_vid_100 \
max-mru=1492 \
name=iprimus password=_password_ \
profile=default-encryption use-peer-dns=yes \
user=fakru******mus.com.au

Step 3: Source NAT for PPPOE interface
/ip firewall nat
add action=masquerade chain=srcnat comment="Source NAT" \
out-interface= iprimus \
to-addresses=0.0.0.0

B. Screenshot:

Screen Shot 2020-01-07 at 9.18.24 pm.png

IMG_20200107_213523.jpg